API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

DrawingHandlerSetActiveDrawing Method (Drawing)

Sets the active drawing that is currently open in Tekla Structures.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public bool SetActiveDrawing(
	Drawing drawing
)

Parameters

drawing
Type: Tekla.Structures.DrawingDrawing
The drawing to be set as the active drawing.

Return Value

Type: Boolean
True on success.
See Also