API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

DrawingHandlerPrintDrawings Method

Prints the list of drawings using the given printer attributes.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public bool PrintDrawings(
	List<Drawing> drawings,
	DPMPrinterAttributes printAttributes
)

Parameters

drawings
Type: System.Collections.GenericListDrawing
The list of drawings to be printed.
printAttributes
Type: Tekla.Structures.DrawingDPMPrinterAttributes
The print attributes for the print job.

Return Value

Type: Boolean
True on success, false if printing fails.
Exceptions
ExceptionCondition
ArgumentExceptionThrown if PDF printing selected, but no file name provided.
ArgumentNullExceptionThrown if drawings or printerAttributes is null.
Remarks
If there is an active drawing visible in the drawing editor and it is a different drawing to the specified drawings, the active drawing will be closed.
See Also