API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

DrawingHandlerPrintDrawing Method (Drawing, PrintAttributes, String)

Prints the drawing to file using the given printer instance. NOTE! The drawing cannot be active, otherwise printing fails.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public bool PrintDrawing(
	Drawing drawing,
	PrintAttributes printAttributes,
	string fileName
)

Parameters

drawing
Type: Tekla.Structures.DrawingDrawing
The drawing to be printed.
printAttributes
Type: Tekla.Structures.DrawingPrintAttributes
The print attributes for the print job.
fileName
Type: SystemString
The name of the output file.

Return Value

Type: Boolean
True on success, false if printing fails.
See Also