DrawingHandlerPrintDrawing Method (Drawing, DPMPrinterAttributes, String)

Prints the drawing to file using the given printer attributes and name of the output file. The given output file overrides the printer attributes file settings.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
public bool PrintDrawing(
	Drawing drawing,
	DPMPrinterAttributes printAttributes,
	string outputFile
)

Parameters

drawing
Type: Tekla.Structures.DrawingDrawing
The drawing to be printed.
printAttributes
Type: Tekla.Structures.DrawingDPMPrinterAttributes
The print attributes for the print job.
outputFile
Type: SystemString
The print output file name.

Return Value

Type: Boolean
True on success, false if printing fails.
Exceptions
ExceptionCondition
ArgumentExceptionThrown if PDF printing selected, but no file name provided.
ArgumentNullExceptionThrown if drawing or printerAttributes is null.
Remarks
If there is an active drawing visible in the drawing editor and it is a different drawing to the specified drawing, the active drawing will be closed.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next