API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

DrawingHandlerGetMessageExecutionStatus Method

Note: This API is now obsolete.

Gets the current message execution mode for the application.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
[ObsoleteAttribute("GetMessageExecutionStatus is obsolete and defaults always to BY_COMMIT.", 
	false)]
public static DrawingHandlerMessageExecutionModeEnum GetMessageExecutionStatus()

Return Value

Type: DrawingHandlerMessageExecutionModeEnum
The current message execution mode.
See Also