API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

DrawingEnumeratorBaseGetEnumerator Method

Allows the usage of the foreach statement with DrawingObjectEnumerator.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public IEnumerator GetEnumerator()

Return Value

Type: IEnumerator
A pointer to the existing instance of the class.
See Also