API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

DrawingIsSameDatabaseObject Method

Returns true if the current object and the given object are referencing the same database object.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public override bool IsSameDatabaseObject(
	DatabaseObject Object
)

Parameters

Object
Type: Tekla.Structures.DrawingDatabaseObject
The other object to be used.

Return Value

Type: Boolean
True if the objects are referencing the same database object.
See Also