API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

DrawingDelete Method

Deletes the drawing. An active drawing cannot be deleted.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public override bool Delete()

Return Value

Type: Boolean
True on success.
Exceptions
ExceptionCondition
CannotDeleteActiveDrawingExceptionThrown if the drawing is active.
See Also