![]() | Drawing Class |
The Drawing class represents a drawing in Tekla Structures.

SystemObject
Tekla.Structures.DrawingDatabaseObject
Tekla.Structures.DrawingDrawing
Tekla.Structures.DrawingAssemblyDrawing
Tekla.Structures.DrawingCastUnitDrawing
Tekla.Structures.DrawingGADrawing
Tekla.Structures.DrawingMultiDrawing
Tekla.Structures.DrawingSinglePartDrawing
Tekla.Structures.DrawingDatabaseObject
Tekla.Structures.DrawingDrawing
Tekla.Structures.DrawingAssemblyDrawing
Tekla.Structures.DrawingCastUnitDrawing
Tekla.Structures.DrawingGADrawing
Tekla.Structures.DrawingMultiDrawing
Tekla.Structures.DrawingSinglePartDrawing
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1

The Drawing type exposes the following members.

Name | Description | |
---|---|---|
![]() | CommitMessage |
Gets the commit message
|
![]() | CreationDate |
The drawing creation date.
|
![]() | DrawingTypeStr |
The type of the drawing
|
![]() | IsFrozen |
Describes whether the drawing is frozen.
|
![]() | IsIssued |
Describes whether the drawing is issued.
|
![]() | IsIssuedButModified |
Describes whether the drawing is issued but modified since it was issued.
|
![]() | IsLocked |
Describes whether the drawing is locked.
|
![]() | IsLockedBy |
Gets the logged in username that set the drawing to locked
|
![]() | IsMasterDrawing |
Describes whether the drawing is a master drawing (shown with a special symbol on the drawing list).
|
![]() | IsReadyForIssue |
Describes whether the drawing is ready for issue.
|
![]() | IsReadyForIssueBy |
Gets the logged in username that set the drawing Ready for issue
|
![]() | IssuingDate |
The drawing issuing date.
|
![]() | Layout |
Gets the drawing layout attributes.
|
![]() | Mark |
The drawing mark.
|
![]() | ModificationDate |
The drawing modification date.
|
![]() | Name |
The name of the drawing.
|
![]() | OutputDate |
The drawing output date. XS_DISABLE_DRAWING_PLOT_DATE controls whether this date is set.
|
![]() | QueryReturnValue |
Status information about the latest database operation (select, insert, modify, delete).
(Inherited from DatabaseObject.) |
![]() | SectionViewStartLabel |
Gets the drawing attribute for start label of section view
|
![]() | Title1 |
The first drawing title.
|
![]() | Title2 |
The second drawing title.
|
![]() | Title3 |
The third drawing title.
|
![]() | UpToDateStatus |
Gets the drawing up to date status.
|

Name | Description | |
---|---|---|
![]() | CommitChanges |
Commits the changes made to the drawings database so far.
Commit inserts a kind of save-point into the database and the save-point will be retrieved if the user does undo.
Commit also executes all messages.
Please note that you need to also to save the drawings database to persists the changes to disk.
|
![]() | CommitChanges(String) |
Commits the changes made to the drawings database so far.
Commit inserts a kind of save-point into the database and the save-point will be retrieved if the user does undo.
Commit also executes all messages.
Please note that you need to also to save the drawings database to persists the changes to disk.
|
![]() | Delete |
Deletes the drawing. An active drawing cannot be deleted.
(Overrides DatabaseObjectDelete.) |
![]() | GetDoubleUserProperties(DictionaryString, Double) |
Retrieves all double user properties for the object with the given list of names.
(Inherited from DatabaseObject.) |
![]() | GetDoubleUserProperties(ListString, DictionaryString, Double) |
Retrieves all double user properties for the object with the given list of names.
(Inherited from DatabaseObject.) |
![]() ![]() | GetIdsOfUnnumberedDrawings |
Returns the list of identifiers of those drawings in the input that are NOT up to date
regarding numbering in the drawing
|
![]() | GetIntegerUserProperties(DictionaryString, Int32) |
Retrieves all integer user properties for the object with the given list of names.
(Inherited from DatabaseObject.) |
![]() | GetIntegerUserProperties(ListString, DictionaryString, Int32) |
Retrieves all integer user properties for the object with the given list of names.
(Inherited from DatabaseObject.) |
![]() | GetPlotFileName | Get plot file name. |
![]() | GetPlotFileNameExt | Get plot file name. |
![]() | GetSheet |
Gets the sheet of the drawing.
|
![]() | GetStringUserProperties(DictionaryString, String) |
Retrieves all string user properties for the object with the given list of names.
(Inherited from DatabaseObject.) |
![]() | GetStringUserProperties(ListString, DictionaryString, String) |
Retrieves all string user properties for the object with the given list of names.
(Inherited from DatabaseObject.) |
![]() | GetUserProperty(String, Double) |
Gets a double property from the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) |
![]() | GetUserProperty(String, Int32) |
Gets an integer property from the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) |
![]() | GetUserProperty(String, String) |
Gets a string property from the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) |
![]() | Insert |
Inserts the object instance into the database. The inserted instance must be of a real type.
(Inherited from DatabaseObject.) |
![]() | IsSameDatabaseObject |
Returns true if the current object and the given object are referencing the same database object.
(Overrides DatabaseObjectIsSameDatabaseObject(DatabaseObject).) |
![]() | Modify |
Modifies the instance in the database.
(Inherited from DatabaseObject.) |
![]() | PlaceViews |
Places views on the sheet.
Computes the required size of the views to fit the parts, then places the views so that they fit on the sheet and do not overlap.
Adjusts the sheet size if needed.
|
![]() | Select |
Selects the object instance from the database.
(Inherited from DatabaseObject.) |
![]() | SetUserProperty(String, Double) |
Sets a double property for the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) |
![]() | SetUserProperty(String, Int32) |
Sets an integer property for the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) |
![]() | SetUserProperty(String, String) |
Sets a string property for the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) |