![]() | DPMPrinterAttributes Class |
The DPMPrinterAttributes class contains the attributes for controlling the printing.

SystemObject
Tekla.Structures.DrawingGenericAttributesBase
Tekla.Structures.DrawingDPMPrinterAttributes
Tekla.Structures.DrawingGenericAttributesBase
Tekla.Structures.DrawingDPMPrinterAttributes
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1

The DPMPrinterAttributes type exposes the following members.

Name | Description | |
---|---|---|
![]() | DPMPrinterAttributes |
Creates a new PrintAttributes instance.
|

Name | Description | |
---|---|---|
![]() | ColorMode |
Output color mode.
|
![]() | NumberOfCopies |
The number of copies of each drawing to print.
Only applicable for printing to a printer.
|
![]() | OpenFileWhenFinished |
Whether to open file when finished.
|
![]() | Orientation |
The print orientation type.
|
![]() | OutputFileName |
Output file name and path. Applicable in PDF printing.
|
![]() | OutputType |
The printing output type.
|
![]() | PaperSize |
The paper size name.
|
![]() | PrinterName |
The printer name.
|
![]() | PrintToMultipleSheet |
Whether to print to multiple sheets.
|
![]() | ScaleFactor |
The print scale factor.
|
![]() | ScalingMethod |
The print scaling method.
|

Name | Description | |
---|---|---|
![]() | IsEqual |
Compares the current object with an object of the same type.
(Overrides GenericAttributesBaseIsEqual(Object).) |