API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

DimensionSetBaseAttributesDimensionValuePrecisions Enumeration

The value precisions for the dimensions.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public enum DimensionValuePrecisions
Members
  Member nameValueDescription
Whole1 The value is rounded to the nearest whole (1).
OnePerTwo2 The value is rounded to the nearest half (1/2).
OnePerThree3 The value is rounded to the nearest third (1/3).
OnePerFour4 The value is rounded to the nearest fourth (1/4).
OnePerEight8 The value is rounded to the nearest eighth (1/8).
OnePerSixteen16 The value is rounded to the nearest sixteenth (1/16).
OnePerThirtytwo32 The value is rounded to the nearest thirtysecond (1/32).
OnePerTen10 The value is rounded to one decimal (1/10).
OnePerHundred100 The value is rounded to two decimals (1/100).
OnePerThousand1000 The value is rounded to three decimals (1/1000).
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.