API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

DimensionSetBaseAttributesDimensionTypes Enumeration

The dimension types.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public enum DimensionTypes
Members
  Member nameValueDescription
Relative1 The point to point dimensions.
Absolute2 The dimensions from a common starting point.
RelativeAndAbsolute3 The combination of point to point and a common start point.
USAbsolute4 The dimensions from a common starting point, which includes a running dimension mark (RD).
USAbsolute216 The dimensions from a common starting point, which includes a running dimension mark (RD), but short dimensions are changed to point to point dimensions.
AbsoluteWithShortRelatives35 The dimensions from a common starting point, but short dimensions are changed to point to point dimensions.
AbsoluteWithAllRelativesAbove99 The combination of point to point and a common start point, but the point to point dimensions are placed above the absolute.
Elevation8 Creates an elevation dimension at a picked point.
See Also