API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

DimensionSetBaseAttributesDimensionTextAttributes Constructor (FontAttributes, DimensionSetBaseAttributesFrameTypes, DimensionSetBaseAttributesDimensionTextPlacings)

Creates a new dimension text attributes instance with the given parameters.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public DimensionTextAttributes(
	FontAttributes font,
	DimensionSetBaseAttributesFrameTypes frame,
	DimensionSetBaseAttributesDimensionTextPlacings textPlacing
)

Parameters

font
Type: Tekla.Structures.DrawingFontAttributes
The font attributes of the dimension value text.
frame
Type: Tekla.Structures.DrawingDimensionSetBaseAttributesFrameTypes
The frame type of the dimension value text.
textPlacing
Type: Tekla.Structures.DrawingDimensionSetBaseAttributesDimensionTextPlacings
The place of the dimension value text.
See Also