API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

DimensionSetBaseAttributesDimensionPlacingAttributes Constructor (DimensionSetBaseAttributesPlacings, PlacingDirectionAttributes, PlacingDistanceAttributes)

Creates a new dimension placing attributes instance with the given parameters.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public DimensionPlacingAttributes(
	DimensionSetBaseAttributesPlacings placing,
	PlacingDirectionAttributes direction,
	PlacingDistanceAttributes distance
)

Parameters

placing
Type: Tekla.Structures.DrawingDimensionSetBaseAttributesPlacings
The placing type of the dimension.
direction
Type: Tekla.Structures.DrawingPlacingDirectionAttributes
The placing direction attributes of the dimension.
distance
Type: Tekla.Structures.DrawingPlacingDistanceAttributes
The placing distance attributes of the dimension.
See Also