![]() | DimensionSetBaseAttributes Class |
The DimensionSetBaseAttributes class is the base class for all dimension set attributes.
The class contains attributes that are common to all dimension sets.

SystemObject
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingDimensionSetBaseAttributes
Tekla.Structures.DrawingAngleDimensionAttributes
Tekla.Structures.DrawingCurvedDimensionSetBaseCurvedDimensionSetBaseAttributes
Tekla.Structures.DrawingRadiusDimensionAttributes
Tekla.Structures.DrawingStraightDimensionSetStraightDimensionSetAttributes
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingDimensionSetBaseAttributes
Tekla.Structures.DrawingAngleDimensionAttributes
Tekla.Structures.DrawingCurvedDimensionSetBaseCurvedDimensionSetBaseAttributes
Tekla.Structures.DrawingRadiusDimensionAttributes
Tekla.Structures.DrawingStraightDimensionSetStraightDimensionSetAttributes
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1

The DimensionSetBaseAttributes type exposes the following members.

Name | Description | |
---|---|---|
![]() | DimensionSetBaseAttributes |
Creates a new default dimension set base attributes instance that loads standard attributes.
|
![]() | DimensionSetBaseAttributes(String) |
Creates a new dimension set base attributes instance that loads the specified attributes.
|

Name | Description | |
---|---|---|
![]() | Arrowhead |
The arrowhead attributes of the dimension.
|
![]() | Color |
The color of the dimension line.
|
![]() | Format |
The format attributes of the dimension.
|
![]() | Placing |
The placing attributes of the dimension.
|
![]() | Text |
The text attributes of the dimension.
|
![]() | TransparentBackground |
The dimension text background transparency. (transparent/opaque)
|

Name | Description | |
---|---|---|
![]() | IsEqual |
Compares the current object with an object of the same type.
(Inherited from AttributesBase.) |
![]() | LoadAttributes |
Loads the attributes from the specified file.
(Inherited from AttributesBase.) |