API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

DimensionSetBaseGetObjects Method (Type)

Gets the children straight dimensions of the current straight dimension set that are of certain types.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public DrawingObjectEnumerator GetObjects(
	Type[] TypeFilter
)

Parameters

TypeFilter
Type: SystemType
The types of the objects to get.

Return Value

Type: DrawingObjectEnumerator
The children straight dimensions of the current straight dimension set that are of certain types.

Implements

IHasChildrenGetObjects(Type)
See Also