DetailMark Class

The DetailMark class defines a drawing object that illustrates a detail in a specific view.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class DetailMark : DrawingObject

The DetailMark type exposes the following members.

Constructors
  NameDescription
Public methodDetailMark(View, Point, Point, Point)
Creates a new detail mark instance with the given positions.
Public methodDetailMark(View, Point, Point, Point, DetailMarkDetailMarkAttributes)
Creates a new detail mark instance with the given positions and attributes.
Top
Properties
  NameDescription
Public propertyAttributes
The attributes for the detail mark.
Public propertyBoundaryPoint
The boundary point of the mark.
Public propertyCenterPoint
The center point of the mark.
Public propertyLabelPoint
The label point of the mark.
Top
Methods
  NameDescription
Public methodDelete
Deletes the detail mark from the current drawing database.
(Overrides DatabaseObjectDelete.)
Public methodInsert
Inserts the detail mark into the current drawing database.
(Overrides DatabaseObjectInsert.)
Public methodIsEqual
Compares the current object with an object of the same type.
(Overrides DrawingObjectIsEqual(Object).)
Public methodModify
Modifies the detail mark in the current drawing database.
(Overrides DatabaseObjectModify.)
Public methodSelect
Selects the detail mark from the current drawing database.
(Overrides DatabaseObjectSelect.)
Top
Examples
The following code inserts a new detail mark in the current drawing:
using Tekla.Structures.Drawing;
using Tekla.Structures.Geometry3d;

public class DetailMarkExample
{
    public void DetailMarkInsert()
    {
        DrawingHandler myDrawingHandler = new DrawingHandler();
        if (myDrawingHandler.GetConnectionStatus())
        {
            DrawingObjectEnumerator viewsEnumerator = myDrawingHandler.GetActiveDrawing().GetSheet().GetAllViews();
            View view = null;
            if (viewsEnumerator.MoveNext())
                view = viewsEnumerator.Current as View;

            if (view != null)
            {
                DetailMark detailMark = new DetailMark(view, new Point(50, 100), new Point(100, 150), new Point(200, 200));
                detailMark.Insert();
            }
        }
    }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next