DetailMark Class

The DetailMark class defines a drawing object that illustrates a detail in a specific view.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class DetailMark : DrawingObject

The DetailMark type exposes the following members.

Constructors
  NameDescription
Public methodDetailMark(View, Point, Point, Point)
Creates a new detail mark instance with the given positions.
Public methodDetailMark(View, Point, Point, Point, DetailMarkDetailMarkAttributes)
Creates a new detail mark instance with the given positions and attributes.
Top
Properties
  NameDescription
Public propertyAttributes
The attributes for the detail mark.
Public propertyBoundaryPoint
The boundary point of the mark.
Public propertyCenterPoint
The center point of the mark.
Public propertyLabelPoint
The label point of the mark.
Public propertyQueryReturnValue
Status information about the latest database operation (select, insert, modify, delete).
(Inherited from DatabaseObject.)
Top
Methods
  NameDescription
Public methodDelete
Deletes the detail mark from the current drawing database.
(Overrides DatabaseObjectDelete.)
Public methodGetDoubleUserProperties(DictionaryString, Double)
Retrieves all double user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetDoubleUserProperties(ListString, DictionaryString, Double)
Retrieves all double user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetDrawing
Gets the drawing where the drawing object is.
(Inherited from DrawingObject.)
Public methodGetIntegerUserProperties(DictionaryString, Int32)
Retrieves all integer user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetIntegerUserProperties(ListString, DictionaryString, Int32)
Retrieves all integer user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetRelatedObjects
Gets the related objects of the current object.
(Inherited from DrawingObject.)
Public methodGetRelatedObjects(Type)
Gets the related objects of the current object that are of certain types.
(Inherited from DrawingObject.)
Public methodGetStringUserProperties(DictionaryString, String)
Retrieves all string user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetStringUserProperties(ListString, DictionaryString, String)
Retrieves all string user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetUserProperty(String, Double)
Gets a double property from the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodGetUserProperty(String, Int32)
Gets an integer property from the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodGetUserProperty(String, String)
Gets a string property from the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodGetView
Gets the view where the drawing object is.
(Inherited from DrawingObject.)
Public methodInsert
Inserts the detail mark into the current drawing database.
(Overrides DatabaseObjectInsert.)
Public methodIsEqual
Compares the current object with an object of the same type.
(Overrides DrawingObjectIsEqual(Object).)
Public methodIsSameDatabaseObject
Returns true if the current object and the given object are referencing the same database object.
(Inherited from DatabaseObject.)
Public methodModify
Modifies the detail mark in the current drawing database.
(Overrides DatabaseObjectModify.)
Public methodSelect
Selects the detail mark from the current drawing database.
(Overrides DatabaseObjectSelect.)
Public methodSetUserProperty(String, Double)
Sets a double property for the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodSetUserProperty(String, Int32)
Sets an integer property for the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodSetUserProperty(String, String)
Sets a string property for the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodToString
Changes the string presentation of the drawing object.
(Inherited from DrawingObject.)
Top
Examples
The following code inserts a new detail mark in the current drawing:
using Tekla.Structures.Drawing;
using Tekla.Structures.Geometry3d;

public class DetailMarkExample
{
    public void DetailMarkInsert()
    {
        DrawingHandler myDrawingHandler = new DrawingHandler();
        if (myDrawingHandler.GetConnectionStatus())
        {
            DrawingObjectEnumerator viewsEnumerator = myDrawingHandler.GetActiveDrawing().GetSheet().GetAllViews();
            View view = null;
            if (viewsEnumerator.MoveNext())
                view = viewsEnumerator.Current as View;

            if (view != null)
            {
                DetailMark detailMark = new DetailMark(view, new Point(50, 100), new Point(100, 150), new Point(200, 200));
                detailMark.Insert();
            }
        }
    }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next