API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

DatabaseObjectGetUserProperty Method (String, String)

Gets a string property from the drawing object. The object has to be in a drawing before the method can be used.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public bool GetUserProperty(
	string Name,
	ref string Value
)

Parameters

Name
Type: SystemString
The name of the property to be gotten.
Value
Type: SystemString
The value of the property.

Return Value

Type: Boolean
True if the property was gotten successfully.
See Also