API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

DatabaseObjectGetDoubleUserProperties Method (DictionaryString, Double)

Retrieves all double user properties for the object with the given list of names.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public bool GetDoubleUserProperties(
	out Dictionary<string, double> values
)

Parameters

values
Type: System.Collections.GenericDictionaryString, Double
Dictionary of name/value pairs that contain the values of the found user properties with the given names.

Return Value

Type: Boolean
True if the request succeeded (the returned values can still be empty if no UserProperties were found).
See Also