![]() | CustomLineType Class |
The CustomLineType class defines the custom line types of the drawing objects.

Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1

The CustomLineType type exposes the following members.

Name | Description | |
---|---|---|
![]() | Description |
The Description of the custom line type (ASCII representation of the line).
|
![]() | LineDescription |
The description of the custom line type.
Description uses the following format:
List of line segments.
Positive value gives length of filled line segment and
negative value gives length of empty line segment.
0 means a dot.
|
![]() | Name |
The Name of the custom line type.
|

Name | Description | |
---|---|---|
![]() | Clone |
Creates a new object that is a copy of the current instance.
(Overrides LineTypesClone.) |
![]() | Equals |
Returns true if the current object and the given object are equal.
(Overrides LineTypesEquals(Object).) |
![]() | GetHashCode |
Returns a hash code for the object.
(Overrides LineTypesGetHashCode.) |
![]() | IsEqual |
Compares the current object with an object of the same type.
(Overrides LineTypesIsEqual(Object).) |
![]() | ToString |
Returns the LineTypes information as a string.
(Inherited from LineTypes.) |

Name | Description | |
---|---|---|
![]() ![]() | Equality |
Returns true if the current object and the given object are equal.
|
![]() ![]() | Inequality |
Returns true if the current object and the given object are not equal.
|