![]() | CurvedDimensionSetRadialCurvedDimensionSetRadialAttributes Class |
The CurvedDimensionSetRadialAttributes class contains the attributes for managing all the attributes
of the curved dimension with radial reference lines.

SystemObject
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingDimensionSetBaseAttributes
Tekla.Structures.DrawingCurvedDimensionSetBaseCurvedDimensionSetBaseAttributes
Tekla.Structures.DrawingCurvedDimensionSetRadialCurvedDimensionSetRadialAttributes
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingDimensionSetBaseAttributes
Tekla.Structures.DrawingCurvedDimensionSetBaseCurvedDimensionSetBaseAttributes
Tekla.Structures.DrawingCurvedDimensionSetRadialCurvedDimensionSetRadialAttributes
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1

The CurvedDimensionSetRadialCurvedDimensionSetRadialAttributes type exposes the following members.

Name | Description | |
---|---|---|
![]() | CurvedDimensionSetRadialCurvedDimensionSetRadialAttributes |
Creates a new curved dimension set radial attributes instance which loads standard attributes.
|
![]() | CurvedDimensionSetRadialCurvedDimensionSetRadialAttributes(Boolean) |
Creates a new curved dimension set radial attributes instance which loads standard attributes.
If it set to true attributes won't be lodaded. |
![]() | CurvedDimensionSetRadialCurvedDimensionSetRadialAttributes(String) |
Creates a new curved dimension set radial attributes instance that loads the specified attributes.
|

Name | Description | |
---|---|---|
![]() | Arrowhead |
The arrowhead attributes of the dimension.
(Inherited from DimensionSetBaseAttributes.) |
![]() | Color |
The color of the dimension line.
(Inherited from DimensionSetBaseAttributes.) |
![]() | CurvedDimensionType |
The curved dimension type.
|
![]() | DimensionType |
The dimension type.
|
![]() | Format |
The format attributes of the dimension.
(Inherited from DimensionSetBaseAttributes.) |
![]() | Placing |
The placing attributes of the dimension.
(Inherited from DimensionSetBaseAttributes.) |
![]() | Text |
The text attributes of the dimension.
(Inherited from DimensionSetBaseAttributes.) |
![]() | TransparentBackground |
The dimension text background transparency. (transparent/opaque)
(Inherited from DimensionSetBaseAttributes.) |

Name | Description | |
---|---|---|
![]() | IsEqual |
Compares the current object with an object of the same type.
(Overrides AttributesBaseIsEqual(Object).) |
![]() | LoadAttributes |
Loads the attributes from the attribute file.
(Overrides AttributesBaseLoadAttributes(String).) |