![]() | CurvedDimensionSetOrthogonalCurvedDimensionSetOrthogonalAttributes Class |
The CurvedDimensionSetOrthogonalAttributes class contains the attributes for managing all the attributes
of the curved dimension with orthogonal reference lines.

SystemObject
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingDimensionSetBaseAttributes
Tekla.Structures.DrawingCurvedDimensionSetBaseCurvedDimensionSetBaseAttributes
Tekla.Structures.DrawingCurvedDimensionSetOrthogonalCurvedDimensionSetOrthogonalAttributes
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingDimensionSetBaseAttributes
Tekla.Structures.DrawingCurvedDimensionSetBaseCurvedDimensionSetBaseAttributes
Tekla.Structures.DrawingCurvedDimensionSetOrthogonalCurvedDimensionSetOrthogonalAttributes
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1

The CurvedDimensionSetOrthogonalCurvedDimensionSetOrthogonalAttributes type exposes the following members.

Name | Description | |
---|---|---|
![]() | CurvedDimensionSetOrthogonalCurvedDimensionSetOrthogonalAttributes |
Creates a new curved dimension set orthogonal attributes instance which loads standard attributes.
|
![]() | CurvedDimensionSetOrthogonalCurvedDimensionSetOrthogonalAttributes(String) |
Creates a new curved dimension set orthogonal attributes instance that loads the specified attributes.
|

Name | Description | |
---|---|---|
![]() | Arrowhead |
The arrowhead attributes of the dimension.
(Inherited from DimensionSetBaseAttributes.) |
![]() | Color |
The color of the dimension line.
(Inherited from DimensionSetBaseAttributes.) |
![]() | Format |
The format attributes of the dimension.
(Inherited from DimensionSetBaseAttributes.) |
![]() | Placing |
The placing attributes of the dimension.
(Inherited from DimensionSetBaseAttributes.) |
![]() | Text |
The text attributes of the dimension.
(Inherited from DimensionSetBaseAttributes.) |
![]() | TransparentBackground |
The dimension text background transparency. (transparent/opaque)
(Inherited from DimensionSetBaseAttributes.) |

Name | Description | |
---|---|---|
![]() | IsEqual |
Compares the current object with an object of the same type.
(Overrides AttributesBaseIsEqual(Object).) |
![]() | LoadAttributes |
Loads the attributes from the attribute file.
(Overrides AttributesBaseLoadAttributes(String).) |