ContainerView Class

The ContainerView class contains container views that contain other drawing objects, including other views and container views. The drawing sheet is a container view. Container views do not contain drawing representations of model objects.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class ContainerView : ViewBase

The ContainerView type exposes the following members.

Properties
  NameDescription
Public propertyAttributes
Gets or sets the attributes of the current object. Only attributes of the same type as the object are allowed.
(Inherited from DrawingObject.)
Public propertyExtremaCenter
Gets the view extrema center.
(Inherited from ViewBase.)
Public propertyFrameOrigin
The vector from the view origin to the frame origin.
(Inherited from ViewBase.)
Public propertyHeight
The height of the view frame in paper coordinates.
(Inherited from ViewBase.)
Public propertyIsSheet
Gets a value indicating whether the container view is the drawing's sheet.
(Inherited from ViewBase.)
Public propertyOrigin
The view origin coordinates in the sheet.
(Inherited from ViewBase.)
Public propertyQueryReturnValue
Status information about the latest database operation (select, insert, modify, delete).
(Inherited from DatabaseObject.)
Public propertyWidth
The width of the view frame in paper coordinates.
(Inherited from ViewBase.)
Top
Methods
  NameDescription
Public methodDelete
Deletes the view and its children objects from the database.
(Inherited from ViewBase.)
Public methodGetAllObjects
Gets all the objects and their children objects in the view.
(Inherited from ViewBase.)
Public methodGetAllObjects(Type)
Gets all the objects and their children objects in the view that are of a certain type.
(Inherited from ViewBase.)
Public methodGetAllObjects(Type)
Gets all the objects and their children objects in the view that are of certain types.
(Inherited from ViewBase.)
Public methodGetAllViews
Gets all the views that are placed on the container view and their children views.
Public methodGetAxisAlignedBoundingBox
The view size in paper coordinates.
(Inherited from ViewBase.)
Public methodGetDoubleUserProperties(DictionaryString, Double)
Retrieves all double user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetDoubleUserProperties(ListString, DictionaryString, Double)
Retrieves all double user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetDrawing
Gets the drawing where the drawing object is.
(Inherited from DrawingObject.)
Public methodGetIntegerUserProperties(DictionaryString, Int32)
Retrieves all integer user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetIntegerUserProperties(ListString, DictionaryString, Int32)
Retrieves all integer user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetModelObjects
Gets the drawing model objects based on given model object identifier. If used from sheet model objects from all views are returned.
(Inherited from ViewBase.)
Public methodGetObjects
Gets the objects in the view. Does not return child objects (single dimensions, grid lines, views).
(Inherited from ViewBase.)
Public methodGetObjects(Type)
Gets the objects in the view that are of certain types. Does not return child objects (single dimensions, grid lines, views).
(Inherited from ViewBase.)
Public methodGetOriginalDrawing
Gets the drawing on which the view was originally created. @see DrawingObject.GetDrawing() for retrieving the current drawing the object resides on.
(Inherited from ViewBase.)
Public methodGetRelatedObjects
Gets the related objects of the current object.
(Inherited from DrawingObject.)
Public methodGetRelatedObjects(Type)
Gets the related objects of the current object that are of certain types.
(Inherited from DrawingObject.)
Public methodGetStringUserProperties(DictionaryString, String)
Retrieves all string user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetStringUserProperties(ListString, DictionaryString, String)
Retrieves all string user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetUserProperty(String, Double)
Gets a double property from the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodGetUserProperty(String, Int32)
Gets an integer property from the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodGetUserProperty(String, String)
Gets a string property from the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodGetView
Gets the view where the drawing object is.
(Inherited from DrawingObject.)
Public methodGetViews
Gets all the views that are placed on the container view.
Public methodInsert
Inserts the view to the database.
(Inherited from ViewBase.)
Public methodIsEqual
Compares the current object with an object of the same type.
(Overrides ViewBaseIsEqual(Object).)
Public methodIsSameDatabaseObject
Returns true if the current object and the given object are referencing the same database object.
(Inherited from DatabaseObject.)
Public methodModify
Modifies the view in the database.
(Inherited from ViewBase.)
Public methodSelect
Selects the view from the database.
(Inherited from ViewBase.)
Public methodSetUserProperty(String, Double)
Sets a double property for the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodSetUserProperty(String, Int32)
Sets an integer property for the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodSetUserProperty(String, String)
Sets a string property for the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodToString
Changes the string presentation of the drawing object.
(Inherited from DrawingObject.)
Top
Examples
The following example uses a container view to create and insert a new view to the active drawing. A drawing must be open when executing code.
using Tekla.Structures.Drawing;
using Tekla.Structures.Geometry3d;

public class Example
{
       public void Example1()
       {
           DrawingHandler MyDrawingHandler = new DrawingHandler();
           if(MyDrawingHandler.GetConnectionStatus())
           {
               Drawing Drawing = MyDrawingHandler.GetActiveDrawing();
               CoordinateSystem CoordinateSystem = new CoordinateSystem(new Point(), new Vector(1, 0, 0), new Vector(0, 1, 0));

               ContainerView ContainerView = Drawing.GetSheet();

               View newView = new View(ContainerView, CoordinateSystem, CoordinateSystem, new AABB(new Point(0, 0), new Point(1000, 1000, 1000)));
               newView.Insert();
           }
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next