ContainerView Class

The ContainerView class contains container views that contain other drawing objects, including other views and container views. The drawing sheet is a container view. Container views do not contain drawing representations of model objects.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class ContainerView : ViewBase

The ContainerView type exposes the following members.

Properties
  NameDescription
Top
Methods
  NameDescription
Public methodGetAllViews
Gets all the views that are placed on the container view and their children views.
Public methodGetViews
Gets all the views that are placed on the container view.
Public methodIsEqual
Compares the current object with an object of the same type.
(Overrides ViewBaseIsEqual(Object).)
Top
Examples
The following example uses a container view to create and insert a new view to the active drawing. A drawing must be open when executing code.
using Tekla.Structures.Drawing;
using Tekla.Structures.Geometry3d;

public class Example
{
       public void Example1()
       {
           DrawingHandler MyDrawingHandler = new DrawingHandler();
           if(MyDrawingHandler.GetConnectionStatus())
           {
               Drawing Drawing = MyDrawingHandler.GetActiveDrawing();
               CoordinateSystem CoordinateSystem = new CoordinateSystem(new Point(), new Vector(1, 0, 0), new Vector(0, 1, 0));

               ContainerView ContainerView = Drawing.GetSheet();

               View newView = new View(ContainerView, CoordinateSystem, CoordinateSystem, new AABB(new Point(0, 0), new Point(1000, 1000, 1000)));
               newView.Insert();
           }
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next