ContainerElement Class

The ContainerElement class defines container elements. A container element is a mark element that has a frame and contains other mark elements. A container element may also contain container elements to achieve nested frames.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class ContainerElement : ElementBase, 
	ICollection, IEnumerable

The ContainerElement type exposes the following members.

Constructors
  NameDescription
Public methodContainerElement
Initializes a new instance of the ContainerElement class
Top
Properties
  NameDescription
Public propertyCount
Gets the number of elements contained in the ICollection.
Public propertyFrame
The frame of the container element.
Public propertyIsSynchronized
Gets a value indicating whether access to the ICollection is synchronized (thread safe).
Public propertySyncRoot
Gets an object that can be used to synchronize access to the ICollection.
Top
Methods
  NameDescription
Public methodAdd
Adds a new element base to the end of the list.
Public methodClear
Removes all elements from the container instance.
Public methodClone
Clones the object.
(Overrides ElementBaseClone.)
Public methodCopyTo
Copies the elements of the ICollection to an Array, starting at a particular Array index.
Public methodGetEnumerator
Returns an enumerator that iterates through a collection.
Public methodGetUnformattedString
Returns the content as a string without formatting.
(Overrides ElementBaseGetUnformattedString.)
Public methodIsEqual
Compares the current object with an object of the same type.
(Overrides ElementBaseIsEqual(Object).)
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next