API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

CircleCircleAttributes Class

The CircleAttributes class is the attributes class of the circle.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
[SerializableAttribute]
public sealed class CircleAttributes : ClosedGraphicObjectClosedGraphicObjectAttributes

The CircleCircleAttributes type exposes the following members.

Constructors
Properties
  NameDescription
Top
Methods
See Also