API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

Circle Constructor (ViewBase, Point, Double)

Creates a new circle instance with a center point and a radius using standard attributes.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public Circle(
	ViewBase view,
	Point centerPoint,
	double radius
)

Parameters

view
Type: Tekla.Structures.DrawingViewBase
The view to be used.
centerPoint
Type: Tekla.Structures.Geometry3dPoint
The center point to be used.
radius
Type: SystemDouble
The radius to be used.
See Also