API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

CastUnitDrawing Constructor (Identifier, CastUnitDrawingCastUnitDrawingCreationType)

Instantiates a new cast unit drawing with standard attributes for a given cast unit.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public CastUnitDrawing(
	Identifier castUnitIdentifier,
	CastUnitDrawingCastUnitDrawingCreationType castUnitDrawingCreationType
)

Parameters

castUnitIdentifier
Type: Tekla.StructuresIdentifier
The identifier of the model object cast unit.
castUnitDrawingCreationType
Type: Tekla.Structures.DrawingCastUnitDrawingCastUnitDrawingCreationType
Specifies the cast unit drawing creation type (by cast unit id or by cast unit position).
See Also