API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

CastUnitDrawing Constructor (Identifier, Int32)

Instantiates a new cast unit drawing with standard attributes and with a specified sheet number for a given cast unit.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public CastUnitDrawing(
	Identifier castUnitIdentifier,
	int sheetNumber
)

Parameters

castUnitIdentifier
Type: Tekla.StructuresIdentifier
The identifier of the model object cast unit.
sheetNumber
Type: SystemInt32
The sheet number of the drawing.
See Also