API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

CannotPerformOperationDrawingMustBeActiveException Class

The CannotPerformOperationDrawingMustBeActiveException class defines the exception that is thrown when a user tries to do an operation which requires that the drawing is active.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
[SerializableAttribute]
public class CannotPerformOperationDrawingMustBeActiveException : TeklaStructuresDrawingsApplicationException

The CannotPerformOperationDrawingMustBeActiveException type exposes the following members.

Constructors
  NameDescription
Public methodCannotPerformOperationDrawingMustBeActiveException
Creates a new cannot perform operation drawing must be active exception instance.
Top
See Also