API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

CannotModifyNonActiveDrawingException Class

The CannotModifyNonActiveDrawingException class defines the exception that is thrown when a user tries to modify a drawing that is not set as active.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
[SerializableAttribute]
public class CannotModifyNonActiveDrawingException : TeklaStructuresDrawingsApplicationException

The CannotModifyNonActiveDrawingException type exposes the following members.

Constructors
  NameDescription
Public methodCannotModifyNonActiveDrawingException
Creates a new cannot modify non-active drawing exception instance.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.