API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

BaseLineWithArrowAtEndPointPlacingType Class

The BaseLineWithArrowAtEndPointPlacingType class defines a placing type that places the object using the base line placing. The line is drawn and will have an arrow at the end point.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.DrawingPreferredPlacingTypeBase
    Tekla.Structures.DrawingBaseLineWithArrowAtEndPointPlacingType

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
[SerializableAttribute]
public class BaseLineWithArrowAtEndPointPlacingType : PreferredPlacingTypeBase

The BaseLineWithArrowAtEndPointPlacingType type exposes the following members.

Constructors
  NameDescription
Public methodBaseLineWithArrowAtEndPointPlacingType
Creates a new base line with arrow at end point placing type instance.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.