![]() | BaseLinePlacing Class |
The BaseLinePlacing class defines a placing where the
object is placed using a line as a reference.
This will thus define the object's X-axis along that line.

Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1

The BaseLinePlacing type exposes the following members.

Name | Description | |
---|---|---|
![]() | BaseLinePlacing |
Creates a new base line placing instance.
The given two points define the line to be used for the placing.
|

Name | Description | |
---|---|---|
![]() | EndPoint |
Sets the end point of the line that the object is using for the placement.
|
![]() | StartPoint |
Sets the start point of the line that the object is using for the placement.
|

Name | Description | |
---|---|---|
![]() | IsEqual |
Compares the current object with an object of the same type.
(Overrides PlacingBaseIsEqual(Object).) |