API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ArrowheadAttributes Constructor (ArrowheadPositions, ArrowheadTypes, Double, Double)

Creates a new arrowhead attributes instance with the given parameters.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public ArrowheadAttributes(
	ArrowheadPositions arrowPosition,
	ArrowheadTypes head,
	double height,
	double width
)

Parameters

arrowPosition
Type: Tekla.Structures.DrawingArrowheadPositions
The arrowhead position.
head
Type: Tekla.Structures.DrawingArrowheadTypes
The arrowhead type.
height
Type: SystemDouble
The arrowhead height.
width
Type: SystemDouble
The arrowhead width.
See Also