![]() | ArrowheadAttributes Class |
The ArrowheadAttributes class handles attributes related to arrowheads of different objects.

SystemObject
Tekla.Structures.DrawingGenericAttributesBase
Tekla.Structures.DrawingArrowheadAttributes
Tekla.Structures.DrawingGenericAttributesBase
Tekla.Structures.DrawingArrowheadAttributes
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1

The ArrowheadAttributes type exposes the following members.

Name | Description | |
---|---|---|
![]() | ArrowheadAttributes |
Creates a new default arrowhead attributes instance. The default values are ArrowheadPositions.None, ArrowheadTypes.FilledArrow, height 2.0 and width 1.0.
|
![]() | ArrowheadAttributes(ArrowheadPositions, ArrowheadTypes, Double, Double) |
Creates a new arrowhead attributes instance with the given parameters.
|

Name | Description | |
---|---|---|
![]() | ArrowPosition |
The position of the arrowhead. The position is always ArrowheadPositions.Both for dimensions.
|
![]() | Head |
The type of the arrowhead.
|
![]() | Height |
The height of the arrowhead.
|
![]() | Width |
The width of the arrowhead.
|

Name | Description | |
---|---|---|
![]() | IsEqual |
Compares the current object with an object of the same type.
(Overrides GenericAttributesBaseIsEqual(Object).) |