API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

Arc Constructor (ViewBase, Point, Point, Point, ArcArcAttributes)

Creates a new arc instance with the given three points and specified attributes.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public Arc(
	ViewBase inView,
	Point StartPoint,
	Point EndPoint,
	Point CenterPoint,
	ArcArcAttributes inAttributes
)

Parameters

inView
Type: Tekla.Structures.DrawingViewBase
The view to be used.
StartPoint
Type: Tekla.Structures.Geometry3dPoint
The start point to be used.
EndPoint
Type: Tekla.Structures.Geometry3dPoint
The end point to be used.
CenterPoint
Type: Tekla.Structures.Geometry3dPoint
The center point to be used.
inAttributes
Type: Tekla.Structures.DrawingArcArcAttributes
The arc attributes to be used.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.