API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

Arc Constructor (ViewBase, Point, Point, Double)

Creates a new arc instance with standard attributes and the given two points and radius.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public Arc(
	ViewBase inView,
	Point inPoint1,
	Point inPoint2,
	double inRadius
)

Parameters

inView
Type: Tekla.Structures.DrawingViewBase
The view to be used.
inPoint1
Type: Tekla.Structures.Geometry3dPoint
The start point to be used.
inPoint2
Type: Tekla.Structures.Geometry3dPoint
The end point to be used.
inRadius
Type: SystemDouble
The radius to be used.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.