API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

AlongPartCenteredPlacingType Class

The AlongPartCenteredPlacingType class defines a placing type that places the object using the along line placing. The line used will be the part's edge in the center of that line.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.DrawingPreferredPlacingTypeBase
    Tekla.Structures.DrawingAlongPartCenteredPlacingType

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
[SerializableAttribute]
public class AlongPartCenteredPlacingType : PreferredPlacingTypeBase

The AlongPartCenteredPlacingType type exposes the following members.

Constructors
  NameDescription
Public methodAlongPartCenteredPlacingType
Creates a new along part centered placing type instance.
Top
See Also