API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

AlongLineOrWithLeaderLineAndParentObjectAlongPartPlacingType Class

The AlongLineOrWithLeaderLineAndParentObjectAlongPartPlacingType class defines a placing type that places the object using the along line placing as the first option. If there is no room for the first option the fallback option will be used. The fallback option is placing the object with a leader line and rotated to be at the same angle as the connected part.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.DrawingPreferredPlacingTypeBase
    Tekla.Structures.DrawingAlongLineOrWithLeaderLineAndParentObjectAlongPartPlacingType

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
[SerializableAttribute]
public class AlongLineOrWithLeaderLineAndParentObjectAlongPartPlacingType : PreferredPlacingTypeBase

The AlongLineOrWithLeaderLineAndParentObjectAlongPartPlacingType type exposes the following members.

Constructors
  NameDescription
Public methodAlongLineOrWithLeaderLineAndParentObjectAlongPartPlacingType
Creates a new along line or with leader line and parent object along part placing type instance.
Top
See Also