API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ShapeSelectionForm Constructor (ListShapeItem)

Initializes a new instance of the ShapeSelectionForm class.

Namespace:  Tekla.Structures.Dialog.UIControls
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.1
Syntax
public ShapeSelectionForm(
	List<ShapeItem> shapes
)

Parameters

shapes
Type: System.Collections.GenericListShapeItem
The Shapes to be added to the dialog.
See Also