API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ProfileSelectionForm Constructor (ListLibraryProfileItem, ListParametricProfileItem, String)

Creates a new instance of the ProfileSelectionForm selecting the given profile in the tree control.

Namespace:  Tekla.Structures.Dialog.UIControls
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2022.0.13611
Syntax
public ProfileSelectionForm(
	List<LibraryProfileItem> LibraryProfileItems,
	List<ParametricProfileItem> ParametricProfileItems,
	string Profile
)

Parameters

LibraryProfileItems
Type: System.Collections.GenericListLibraryProfileItem
The library profiles to be added to the dialog.
ParametricProfileItems
Type: System.Collections.GenericListParametricProfileItem
The parametric profiles to be added to the dialog.
Profile
Type: SystemString
The profile that will be selected in the tree.
See Also