API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

OkApplyCancel Class

The OkApplyCancel class represents a control including the Ok-Apply-Cancel button group.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Dialog.UIControls
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2022.0.13611
Syntax
public class OkApplyCancel : UserControl

The OkApplyCancel type exposes the following members.

Constructors
  NameDescription
Public methodOkApplyCancel
Initializes a new instance of the OkApplyCancel class.
Top
Events
  NameDescription
Public eventApplyClicked
The ApplyClicked event is raised when the Apply button is clicked.
Public eventCancelClicked
The CancelClicked event is raised when the Cancel button is clicked.
Public eventOkClicked
The OkClicked event is raised when the Ok button is clicked.
Top
See Also