API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

MaterialSelectionForm Constructor (ListMaterialItem, String)

Creates a new instance of the MaterialSelectionForm, selecting the given material in the tree control.

Namespace:  Tekla.Structures.Dialog.UIControls
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2022.0.13611
Syntax
public MaterialSelectionForm(
	List<MaterialItem> Materials,
	string Material
)

Parameters

Materials
Type: System.Collections.GenericListMaterialItem
The materials to be added to the dialog.
Material
Type: SystemString
The material to be selected in the tree.
See Also