API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ImageListComboBoxRefreshOptionList Method

Refreshes the option list content.

Namespace:  Tekla.Structures.Dialog.UIControls
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2022.0.13611
Syntax
public void RefreshOptionList()
Examples
The following example demonstrates how to programmatically add a new item to the combo box:
using System;
using System.Drawing;
using System.Windows.Forms;
using Tekla.Structures.Dialog.UIControls;

public class ImageListComboBoxExample
{
    private ImageListComboBox ImageListComboBox;

    public ImageListComboBoxExample()
    {
        ImageListComboBox = new ImageListComboBox();
    }

    void AddNewImage()
    {
        ImageListComboBox.ImageList.Images.Add("ImageKey", new Bitmap(@"C:\Image.bmp"));
        ImageListComboBox.RefreshOptionList();
    }
}
See Also