API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

EnvironmentVariablesGetEnvironmentVariable Method

Gets an environment variable.

Namespace:  Tekla.Structures.Dialog.UIControls
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2022.0.13611
Syntax
public static string GetEnvironmentVariable(
	string variableName
)

Parameters

variableName
Type: SystemString
The name of the variable to get.

Return Value

Type: String
The environment variable.
See Also