API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

StructuresExtenderGetAttributeTypeName Method

Retrieves the AttributeTypeName text associated with the specified control.

Namespace:  Tekla.Structures.Dialog
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2022.0.13611
Syntax
public string GetAttributeTypeName(
	Control control
)

Parameters

control
Type: System.Windows.FormsControl
The control for which to retrieve the AttributeTypeName text.

Return Value

Type: String
A string containing the AttributeTypeName text for the specified control, or null if no text is associated with the specified control.
See Also