API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

LocalizationLoadXMLFile Method

Loads the localization strings from an xml file. Several files may be used concurrently, just call LoadXMLFile for each file. The translations are searched in the loading order and the first match is returned.

Namespace:  Tekla.Structures.Dialog
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2022.0.13611
Syntax
public void LoadXMLFile(
	string fileName
)

Parameters

fileName
Type: SystemString
The xml file to be loaded.
See Also