API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

HelpViewerDisplayHelpTopic Method

Method for opening Tekla Structures help viewer with given help topic. Method requires Tekla Structures to be running.

Namespace:  Tekla.Structures.Dialog
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2022.0.13611
Syntax
public static bool DisplayHelpTopic(
	string helpTopic
)

Parameters

helpTopic
Type: SystemString
Help topic (e.g. Help file name without extension).

Return Value

Type: Boolean
True if success, otherwise false.
Exceptions
ExceptionCondition
InvalidOperationExceptionThrown when connection to Tekla Structures failed.
See Also