API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

DialogsLoadAttributeFileNameToDialogAndModify Method (String, String)

Loads the specified dialog's current values from the attribute file and modifies the current selected instance.

Namespace:  Tekla.Structures.Dialog
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2022.0.13611
Syntax
public static bool LoadAttributeFileNameToDialogAndModify(
	string attributeFileName,
	string pluginFormName
)

Parameters

attributeFileName
Type: SystemString
The name of the attribute file.
pluginFormName
Type: SystemString
The full name of the dialog.

Return Value

Type: Boolean
True on success.
See Also