API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

DialogsGetPluginFormBaseByPluginFormName Method

Retrieves an instance of the form.

Namespace:  Tekla.Structures.Dialog
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2022.0.13611
Syntax
public static PluginFormBase GetPluginFormBaseByPluginFormName(
	string pluginFormName
)

Parameters

pluginFormName
Type: SystemString
The complete name of the plug-in form (including the plug-in name).

Return Value

Type: PluginFormBase
The existing PluginFormBase or null if it did not exist.
See Also