API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

StringConverterCanConvertTo Method

Checks whether the conversion can be made from the string datatype to the destination type.

Namespace:  Tekla.Structures.Datatype
Assembly:  Tekla.Structures.Datatype (in Tekla.Structures.Datatype.dll) Version: 2022.0.13611
Syntax
public override bool CanConvertTo(
	ITypeDescriptorContext context,
	Type destinationType
)

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
The context.
destinationType
Type: SystemType
The type to convert to.

Return Value

Type: Boolean
True if possible, false if not possible.
See Also